Wireshark / Ethereal < 1.0.15 / 1.2.10 Multiple Vulnerabilities

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has an application that is affected by multiple
vulnerabilities.

Description :

The installed version of Wireshark or Ethereal is potentially
affected by multiple vulnerabilities.

- The SigComp Universal Decompressor Virtual Machine could
potentially overflow a buffer. (Bug 4867)

- The ANS.1 BER dissector could potentially exhaust the
stack memory. (Bug 4984)

- The GSM A RR dissector is affected by denial of service
issue. (Bug 4897)

- The IPMI dissector could get stuck in an infinite loop.
(Bug 5053)

See also :

http://www.wireshark.org/security/wnpa-sec-2010-08.html
http://www.wireshark.org/security/wnpa-sec-2010-07.html

Solution :

Upgrade to Wireshark version 1.0.15 / 1.2.10 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 48213 ()

Bugtraq ID: 42618

CVE ID: CVE-2010-2992
CVE-2010-2993
CVE-2010-2994
CVE-2010-2995

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now