FreeBSD : libmspack -- infinite loop denial of service (43024078-9b63-11df-8983-001d60d86f38)

This script is Copyright (C) 2010-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

There is a denial of service vulnerability in libmspack. The libmspack
code is built into cabextract, so it is also vulnerable.

Secunia reports :

The vulnerability is caused due to an error when copying data from an
uncompressed block (block type 0) and can be exploited to trigger an
infinite loop by tricking an application using the library into
processing specially crafted MS-ZIP archives.

See also :

http://www.nessus.org/u?5565c453

Solution :

Update the affected packages.

Risk factor :

High

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 47904 (freebsd_pkg_430240789b6311df8983001d60d86f38.nasl)

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now