openSUSE Security Update : w3m (openSUSE-SU-2010:0393-1)

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

w3m did not handle embedded nul characters in the common name and in
subject alternative names of x509 certificates. CVE-2010-2074 has been
assigned to this issue. This update also turns on verification of x509
certificates by default which was not the case before.

See also :

http://lists.opensuse.org/opensuse-updates/2010-07/msg00019.html
https://bugzilla.novell.com/show_bug.cgi?id=609451

Solution :

Update the affected w3m packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 47775 ()

Bugtraq ID:

CVE ID: CVE-2010-2074

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now