Winamp < 5.58 Buffer Overflow

This script is Copyright (C) 2010-2011 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a multimedia application that is
affected by a stack-based buffer overflow vulnerability.

Description :

The remote host is running Winamp, a media player for Windows.

The version of Winamp installed on the remote host is earlier than
5.58. Such versions are reportedly affected by a stack-based buffer
overflow vulnerability when parsing VP6 video content. An attacker,
exploiting this flaw, can execute arbitrary code in the context of the
affected application.

See also :

http://www.winamp.com/help/Version_History#Winamp_5.58
http://forums.winamp.com/showthread.php?t=320278

Solution :

Upgrade to Winamp version 5.58 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 47717 ()

Bugtraq ID: 41591

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now