This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.
The remote Apache Tomcat server is affected by multiple
According to its self-reported version number, the instance of Apache
Tomcat listening on the remote host is prior to 6.0.18. It is,
therefore, affected by multiple vulnerabilities :
- The remote Apache Tomcat installation is affected by a
cross-site scripting vulnerability in the
HttpServletResponse.sendError method due to improper
validation of user-supplied input to the 'message'
argument. An attacker can exploit this to execute
arbitrary script code in a user's browser session.
- A cross-site scripting vulnerability exists in the host
manager application due to improper validation of
user-supplied input to the 'hostname' parameter. An
attacker can exploit this to execute arbitrary script
code in a user's browser session. (CVE-2008-1947)
- A traversal vulnerability exists when using a
RequestDispatcher in combination with a servlet or JSP
that allows a remote attacker to utilize a specially
crafted request parameter to access protected web
Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.
See also :
Upgrade to Apache Tomcat version 6.0.18 or later.
Risk factor :
Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.3
Public Exploit Available : true