Fedora 13 : python-2.6.4-27.fc13 (2010-9652)

This script is Copyright (C) 2010-2015 Tenable Network Security, Inc.


Synopsis :

The remote Fedora host is missing a security update.

Description :

- Fri Jun 4 2010 David Malcolm <dmalcolm at redhat.com> -
2.6.4-27

- ensure that the compiler is invoked with '-fwrapv'
(rhbz#594819)

- CVE-2010-1634: fix various integer overflow checks in
the audioop module (patch 113)

- CVE-2010-2089: further checks within the audioop module
(patch 114)

- CVE-2008-5983: the new PySys_SetArgvEx entry point
from r81399 (patch 115)

- Mon Apr 26 2010 Dennis Gilmore <dennis at ausil.us> -
2.6.4-26

- disable --with-valgrind on sparc arches

Note that Tenable Network Security has extracted the preceding
description block directly from the Fedora security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

See also :

https://bugzilla.redhat.com/show_bug.cgi?id=482814
https://bugzilla.redhat.com/show_bug.cgi?id=590690
https://bugzilla.redhat.com/show_bug.cgi?id=598197
http://www.nessus.org/u?ea86d227

Solution :

Update the affected python package.

Risk factor :

Medium / CVSS Base Score : 6.9
(CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.0
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Fedora Local Security Checks

Nessus Plugin ID: 47547 (fedora_2010-9652.nasl)

Bugtraq ID: 40370

CVE ID: CVE-2008-5983
CVE-2010-1634
CVE-2010-2089

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now