Adobe AIR < 2.0.2.12610 Multiple Vulnerabilities (ASPB10-14)

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a version of Adobe AIR that is
affected by multiple vulnerabilities.

Description :

The remote Windows host contains a version of Adobe AIR that is
earlier than 2.0.2.12610. Such versions are affected by multiple
vulnerabilities, such as memory corruption, buffer overflows, and
memory exhaustion, that could be exploited to cause an application
crash or even allow execution of arbitrary code.

See also :

http://www.adobe.com/support/security/bulletins/apsb10-14.html

Solution :

Upgrade to Adobe AIR 2.0.2.12610 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:H/RL:OF/RC:ND)
Public Exploit Available : true