openSUSE Security Update : irssi (openSUSE-SU-2010:0183-1)

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

irssi did not check the identity information of a remote hosts's
certificate. Attackers could exploit that for a man-in-the-middle
attack (CVE-2010-1155).

irssi could crash if someone changed nick while the victim was leaving
the channel (CVE-2010-1156).

See also :

http://lists.opensuse.org/opensuse-updates/2010-04/msg00091.html
https://bugzilla.novell.com/show_bug.cgi?id=596005

Solution :

Update the affected irssi packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 46188 ()

Bugtraq ID:

CVE ID: CVE-2010-1155
CVE-2010-1156

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now