FreeBSD : irssi -- multiple vulnerabilities (3b7967f1-49e8-11df-83fb-0015587e2cc1)

This script is Copyright (C) 2010-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

Two vulnerabilities have found in irssi. The first issue could allow
man-in-the-middle attacks due to a missing comparison of SSL server
hostnames and the certificate domain names (e.g. CN).

A second vulnerability, related to the nick matching code, could be
triggered by remote attackers in order to crash an irssi client when
leaving a channel.

See also :

http://xforce.iss.net/xforce/xfdb/57790
http://xforce.iss.net/xforce/xfdb/57791
http://www.nessus.org/u?35c055ab

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 45570 (freebsd_pkg_3b7967f149e811df83fb0015587e2cc1.nasl)

Bugtraq ID:

CVE ID: CVE-2010-1155
CVE-2010-1156

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now