openSUSE Security Update : java-1_6_0-sun (java-1_6_0-sun-2228)

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

Sun Java 6 was updated to Update 19, fixing a large number of security
issues.

CVE-2009-3555 CVE-2010-0082 CVE-2010-0084 CVE-2010-0085 CVE-2010-0087
CVE-2010-0088 CVE-2010-0089 CVE-2010-0090 CVE-2010-0091 CVE-2010-0092
CVE-2010-0093 CVE-2010-0094 CVE-2010-0095 CVE-2010-0837 CVE-2010-0838
CVE-2010-0839 CVE-2010-0840 CVE-2010-0841 CVE-2010-0842 CVE-2010-0843
CVE-2010-0844 CVE-2010-0845 CVE-2010-0846 CVE-2010-0847 CVE-2010-0848
CVE-2010-0849 CVE-2010-0850

See also :

https://bugzilla.novell.com/show_bug.cgi?id=578877
https://bugzilla.novell.com/show_bug.cgi?id=592589

Solution :

Update the affected java-1_6_0-sun packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
Public Exploit Available : true