OpenSSL < 0.9.8m Multiple Vulnerabilities

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server has multiple SSL-related vulnerabilities.

Description :

According to its banner, the remote web server uses a version of
OpenSSL older than 0.9.8m. Such versions have the following
vulnerabilities :

- Session renegotiations are not handled properly, which could
be exploited to insert arbitrary plaintext by a
man-in-the-middle. (CVE-2009-3555)

- The library does not check for a NULL return value from calls
to the bn_wexpand() function, which has unspecified impact.

- A memory leak in the zlib_stateful_finish function in crypto/comp/c_zlib.c
allows remote attackers to cause a denial of service via vectors that
trigger incorrect calls to the CRYPTO_cleanup_all_ex_data function.
(CVE-2008-1678, CVE-2009-4355)

For this vulnerability to be exploitable, compression must be enabled in OpenSSL
for SSL/TLS connections.

See also :

Solution :

Upgrade to OpenSSL 0.9.8m or later.

Risk factor :

Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 8.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 45039 ()

Bugtraq ID: 31692

CVE ID: CVE-2006-4343

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now