Apache 1.3.x < 1.3.42 mod_proxy Integer Overflow

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server may be affected by an integer overflow

Description :

According to its banner, the version of Apache 1.3.x running on the
remote host is prior 1.3.42. It is, therefore, potentially affected
by an integer overflow vulnerability in the mod_proxy Apache module.
A remote attacker can exploit this to cause a denial of service
condition or to execute arbitrary code.

Note that successful exploitation is possible only on platforms where
sizeof(int) < sizeof(long), such as 64-bit architectures.

Also note that version 1.3.42 is the final release of Apache 1.3.

See also :


Solution :

Upgrade to Apache version 1.3.42 or later. Alternatively, disable

Risk factor :

Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 7.8
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 44589 (apache_1_3_42.nasl)

Bugtraq ID: 37966

CVE ID: CVE-2010-0010

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now