Wireshark / Ethereal Dissector LWRES Multiple Buffer Overflows

This script is Copyright (C) 2010-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has an application that is affected by several buffer
overflows.

Description :

The installed version of Wireshark or Ethereal is potentially
vulnerable to attack by handling data associated with the LWRES
dissector.

These vulnerabilities can result in a denial of service, or possibly
arbitrary code execution. A remote attacker can exploit these issues
by tricking a user into opening a maliciously crafted capture file.
Additionally, if Wireshark is running in promiscuous mode, one of
these issues can be exploited remotely.

See also :

http://www.wireshark.org/security/wnpa-sec-2010-02.html

Solution :

Upgrade to Wireshark version 1.0.11 / 1.2.6 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 44338 ()

Bugtraq ID: 37985

CVE ID: CVE-2010-0304

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now