This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.
The remote SSH service may be affected by multiple vulnerabilities.
According to its banner, the version of OpenSSH running on the remote
host is earlier than 5.7. Versions before 5.7 may be affected by the
following vulnerabilities :
- A security bypass vulnerability because OpenSSH does not
properly validate the public parameters in the J-PAKE
protocol. This could allow an attacker to authenticate
without the shared secret. Note that this issue is only
exploitable when OpenSSH is built with J-PAKE support,
which is currently experimental and disabled by default,
and that Nessus has not checked whether J-PAKE support
is indeed enabled. (CVE-2010-4478)
- The auth_parse_options function in auth-options.c in
sshd provides debug messages containing authorized_keys
command options, which allows remote, authenticated
users to obtain potentially sensitive information by
reading these messages. (CVE-2012-0814)
See also :
Upgrade to OpenSSH 5.7 or later.
Risk factor :
Medium / CVSS Base Score : 6.8
CVSS Temporal Score : 5.9
Public Exploit Available : false