openSUSE Security Update : MozillaFirefox (MozillaFirefox-1708)

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

The Mozilla Firefox was updated to version 3.5.6, fixing lots of bugs
and various security issues.

The following issues were fixed :

- MFSA 2009-65/CVE-2009-3979/CVE-2009-3980/CVE-2009-3982
Crashes with evidence of memory corruption (rv:1.9.1.6)

- MFSA 2009-66/CVE-2009-3388 (bmo#504843,bmo#523816)
Memory safety fixes in liboggplay media library

- MFSA 2009-67/CVE-2009-3389 (bmo#515882,bmo#504613)
Integer overflow, crash in libtheora video library

- MFSA 2009-68/CVE-2009-3983 (bmo#487872) NTLM reflection
vulnerability

- MFSA 2009-69/CVE-2009-3984/CVE-2009-3985
(bmo#521461,bmo#514232) Location bar spoofing
vulnerabilities

- MFSA 2009-70/CVE-2009-3986 (bmo#522430) Privilege
escalation via chrome window.opener

See also :

https://bugzilla.novell.com/show_bug.cgi?id=559807

Solution :

Update the affected MozillaFirefox packages.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 43383 ()

Bugtraq ID:

CVE ID: CVE-2009-3388
CVE-2009-3389
CVE-2009-3979
CVE-2009-3980
CVE-2009-3982
CVE-2009-3983
CVE-2009-3984
CVE-2009-3985
CVE-2009-3986

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now