Wireshark / Ethereal 0.9.0 to 1.2.4 Multiple Vulnerabilities

This script is Copyright (C) 2009-2013 Tenable Network Security, Inc.


Synopsis :

The remote host has an application that is affected by multiple
vulnerabilities

Description :

The installed version of Wireshark or Ethereal is potentially
affected by multiple vulnerabilities :

- The Daintree SNA file parser can overflow a buffer.
(Bug 4294)

- The SMB and SMB2 dissectors can crash. (Bug 4301)

- The IPMI dissector can crash on Windows. (Bug 4319)

These vulnerabilities can result in a denial of service, or possibly
arbitrary code execution. A remote attacker can exploit these issues
by tricking a user into opening a maliciously crafted capture file.
Additionally, if Wireshark is running in promiscuous mode, one of
these issues can be exploited remotely (from the same network
segment).

See also :

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=4294
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=4301
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=4319
http://www.wireshark.org/security/wnpa-sec-2009-09.html

Solution :

Upgrade to Wireshark version 1.2.5 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 43350 ()

Bugtraq ID: 37407

CVE ID: CVE-2009-4376
CVE-2009-4377
CVE-2009-4378

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now