Winamp < 5.57 Multiple Vulnerabilities

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a multimedia application that is
affected by multiple vulnerabilities.

Description :

The remote host is running Winamp, a media player for Windows.

The version of Winamp installed on the remote host is earlier than
5.57. Such versions are potentially affected by multiple issues :

- A boundary error in the Module Decoder Plug-in exists
when parsing samples and can be exploited to cause a
heap-based buffer overflow. (CVE-2009-3995)

- An error in the Module Decoder Plug-in when parsing
'Ultratracker' fields and can be exploited to cause a
heap-based buffer overflow. (CVE-2009-3996)

- An integer overflow error in the Module Decoder Plug-in
when parsing 'Oktalyzer' files and can be exploited to
cause a heap-based buffer overflow. (CVE-2009-3997)

- Integer overflow errors within the 'jpeg.w5s' and
'png.w5s' filters when processing malformed 'JPEG' or
'PNG' data in a media file. (CVE-2009-4356)

See also :

http://www.nessus.org/u?0e4f075b
http://secunia.com/secunia_research/2009-53/
http://secunia.com/secunia_research/2009-56/
http://secunia.com/secunia_research/2009-57/
http://www.securityfocus.com/archive/1/508532/30/0/threaded

Solution :

Upgrade to Winamp version 5.57 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 43181 ()

Bugtraq ID: 37374
37387

CVE ID: CVE-2009-3995
CVE-2009-3996
CVE-2009-3997
CVE-2009-4356

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now