Shockwave Player <= 11.5.1.601 Multiple Vulnerabilities (APSB09-16)

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser plugin that is affected
by multiple vulnerabilities.

Description :

The remote Windows host contains a version of Adobe's Shockwave Player
that is 11.5.1.601 or earlier. As such, it is affected by multiple
issues :

- An invalid index vulnerability could lead to code
execution. (CVE-2009-3463)

- Invalid pointer vulnerabilities could lead to code
execution. (CVE-2009-3464, CVE-2009-3465)

- An invalid string length vulnerability could potentially
lead to code execution. (CVE-2009-3466)

- A boundary condition issue could lead to a denial
of service. (CVE-2009-3244)

See also :

http://www.adobe.com/support/security/bulletins/apsb09-16.html

Solution :

Upgrade to Adobe Shockwave version 11.5.2.602 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 42369 ()

Bugtraq ID: 36905

CVE ID: CVE-2009-3244
CVE-2009-3463
CVE-2009-3464
CVE-2009-3465
CVE-2009-3466

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now