SeaMonkey < 2.0 Multiple Vulnerabilities

This script is Copyright (C) 2009-2017 Tenable Network Security, Inc.


Synopsis :

A web browser on the remote host is affected by multiple
vulnerabilities.

Description :

The installed version of SeaMonkey is earlier than 2.0. Such
versions are potentially affected by the following security
issues :

- Provided the browser is configured to use Proxy
Auto-configuration it may be possible for an attacker to
crash the browser or execute arbitrary code.
(MFSA 2009-55)

- Mozilla's GIF image parser is affected by a heap-based
buffer overflow. (MFSA 2009-56)

- If a file contains right-to-left override character
(RTL) in the filename it may be possible for an attacker
to obfuscate the filename and extension of the file
being downloaded. (MFSA 2009-62)

See also :

https://www.mozilla.org/en-US/security/advisories/mfsa2009-55/
https://www.mozilla.org/en-US/security/advisories/mfsa2009-56/
https://www.mozilla.org/en-US/security/advisories/mfsa2009-62/

Solution :

Upgrade to SeaMonkey 2.0 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 42307 ()

Bugtraq ID: 36855
36856
36867

CVE ID: CVE-2009-3372
CVE-2009-3373
CVE-2009-3376

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now