openSUSE 10 Security Update : dhcp (dhcp-6336)

This script is Copyright (C) 2009-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

The DHCP client (dhclient) could be crashed by a malicious DHCP server
sending a overlong subnet field. (CVE-2009-0692)

In some circumstances code execution might be possible, but might is
likely caught by the buffer overflow checking of the FORTIFY_SOURCE
extension.

Solution :

Update the affected dhcp packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 41996 ()

Bugtraq ID:

CVE ID: CVE-2009-0692

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now