Samba < 3.0.37 / 3.2.15 / 3.3.8 / 3.4.2 Multiple Vulnerabilities

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.

Synopsis :

The remote Samba server may be affected by multiple vulnerabilities.

Description :

According to its banner, the version of Samba server on the remote
host is earlier than 3.0.37 / 3.2.15 / 3.3.8 / 3.4.2. Such versions
are potentially affected by multiple issues :

- If a user in '/etc/passwd' is misconfigured to have an
empty home directory, then connecting to the home share
of this user will use the root of the file system as the
home directory. (CVE-2009-2813)

- Specially crafted SMB requests on authenticated
SMB connections can send smbd into a 100% loop, causing
a denial of service. (CVE-2009-2906)

- When 'mount.cifs' is installed as a setuid program, a
user can pass it a credential or password path to which
he or she does not have access and then use the
'--verbose' option to view the first line of that file.

See also :

Solution :

Upgrade to Samba 3.0.37 / 3.2.15 / 3.3.8 / 3.4.2 or later.

Risk factor :

Medium / CVSS Base Score : 6.0
CVSS Temporal Score : 5.2
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 41970 ()

Bugtraq ID: 36572

CVE ID: CVE-2009-2813

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now