openSUSE Security Update : postgresql (postgresql-1322)

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

Multiple security vulnerabilities have been fixed in PostgrSQL

- CVE-2009-3229: allows remote authenticated users to
cause a denial of service

- CVE-2009-3230: allows remote authenticated users to gain
higher privileges

- CVE-2009-3231: when using LDAP authentication with
anonymous binds, allows remote attackers to bypass
authentication via an empty password

See also :

https://bugzilla.novell.com/show_bug.cgi?id=537706

Solution :

Update the affected postgresql packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 41939 ()

Bugtraq ID:

CVE ID: CVE-2009-3229
CVE-2009-3230
CVE-2009-3231

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now