Pidgin < 2.6.1 Multiple Vulnerabilities

This script is Copyright (C) 2009-2011 Tenable Network Security, Inc.


Synopsis :

The remote host has an instant messaging client that is affected by
multiple vulnerabilities.

Description :

The version of Pidgin installed on the remote host is earlier than
2.6.1. Such versions are reportedly affected by one or more of
following issues :

- The Yahoo protocol plugin may crash when receiving an IM
from any user that contains a URL. (CVE-2009-3025)

- The XMPP protocol plugin can be tricked into establishing
an insecure connection by a malicious man-in-the-middle by
causing libpurple to use the older IQ-based login and then
not offering TLS/SSL. (CVE-2009-3026)

See also :

http://pidgin.im/news/security/?id=36
http://pidgin.im/news/security/?id=35

Solution :

Upgrade to Pidgin 2.6.1 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 40986 ()

Bugtraq ID: 36367
36368

CVE ID: CVE-2009-3025
CVE-2009-3026

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now