Adobe Acrobat < 9.1.2 / 8.1.6 / 7.1.3 Multiple Vulnerabilities

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The version of Adobe Acrobat on the remote Windows host is affected by
multiple vulnerabilities.

Description :

The version of Adobe Acrobat installed on the remote host is earlier
than 9.1.2 / 8.1.6 / 7.1.3. Such versions are reportedly affected by
multiple vulnerabilities :

- A stack-based buffer overflow can lead to code
execution. (CVE-2009-1855)

- An integer buffer overflow can result in an application
crash and possibly code execution, although that has
not been shown yet. (CVE-2009-1856)

- A memory corruption issue can result in an application
crash and possibly code execution, although that has
not been shown yet. (CVE-2009-1857)

- A memory corruption issue in the JBIG2 filter can lead
to code execution. (CVE-2009-1858)

- A memory corruption issue can lead to code execution.
(CVE-2009-1859)

- A memory corruption issue in the JBIG2 filter can
result in an application crash and possibly code
execution, although that has not been shown yet.
(CVE-2009-0198)

- Multiple heap buffer overflow vulnerabilities in the
JBIG2 filter can lead to code execution.
(CVE-2009-0509, CVE-2009-0510, CVE-2009-0511,
CVE-2009-0512, CVE-2009-0888, CVE-2009-0889)

- Multiple heap-based buffer overflow vulnerabilities can
lead to code execution. (CVE-2009-1861)

See also :

http://www.adobe.com/support/security/bulletins/apsb09-07.html

Solution :

Upgrade to Adobe Acrobat 9.1.2 / 8.1.6 / 7.1.3 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now