Google Chrome < 2.0.172.43 Multiple Vulnerabilities

This script is Copyright (C) 2009-2017 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web browser that is affected by multiple
vulnerabilities.

Description :

The version of Google Chrome installed on the remote host is earlier
than 2.0.172.43. Such versions are reportedly affected by multiple
issues :

- A flaw in the V8 JavaScript engine might allow a
specially crafted JavaScript page to access
unauthorized data in memory or to execute arbitrary code
within the Google Chrome sandbox. (CVE-2009-2935)

- The browser can connect to SSL-enabled sites whose
certificates use weak hash algorithms, such as MD2 and
MD4. An attacker may be able exploit this issue to
forge certificates and spoof an invalid website as a
valid HTTPS site. (Issue #18725)

- A stack consumption vulnerability in libxml2 library
could be exploited to crash the Google Chrome tab process
or execute arbitrary code with in Google Chrome sandbox.
(CVE-2009-2414)

- Multiple use-after-free vulnerabilities in libxml2
library could be exploited to crash the Google Chrome
tab process or execute arbitrary code with in Google
Chrome sandbox. (CVE-2009-2416)

See also :

https://bugs.chromium.org/p/chromium/issues/detail?id=18639
https://bugs.chromium.org/p/chromium/issues/detail?id=18725
http://www.nessus.org/u?c3047265

Solution :

Upgrade to Google Chrome 2.0.172.43 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 40778 (google_chrome_2_0_172_43.nasl)

Bugtraq ID: 36010
36149

CVE ID: CVE-2009-2414
CVE-2009-2416
CVE-2009-2935

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now