Safari < 4.0.3 Multiple Vulnerabilities

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web browser that is affected by several
vulnerabilities.

Description :

The version of Safari installed on the remote Windows host is earlier
than 4.0.3. Such versions are potentially affected by several
issues :

- A buffer overflow exists in the handling of EXIF
metadata that ccould lead to a crash or arbitrary code
execution. (CVE-2009-2188)

- A vulnerability in WebKit's parsing of floating point
numbers may allow for remote code execution.
(CVE-2009-2195)

- A vulnerability in Safari may allow a malicious website
to be promoted in Safari's Top Sites. (CVE-2009-2196)

- A vulnerability in how WebKit renders an URL with look-
alike characters could be used to masquerade a website.
(CVE-2009-2199)

- A vulnerability in WebKit may lead to the disclosure of
sensitive information. (CVE-2009-2200)

- A heap-based buffer overflow in CoreGraphics involving
the drawing of long text strings could lead to a crash
or arbitrary code execution. (CVE-2009-2468)

See also :

http://support.apple.com/kb/HT3733
http://lists.apple.com/archives/security-announce/2009/Aug/msg00002.html
http://www.securityfocus.com/advisories/17616

Solution :

Upgrade to Safari 4.0.3 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now