Shockwave Player < 11.5.0.601 Multiple Vulnerabilities (APSB09-11)

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an Internet Explorer plugin which
uses a vulnerable version of the Microsoft Active Template Library
(ATL).

Description :

The remote Windows host contains a version of Adobe's Shockwave Player
that is earlier than 11.5.0.601. Such versions were compiled against a
version of Microsoft's Active Template Library (ATL) that contained a
vulnerability. If an attacker can trick a user of the affected
software into opening such a file, this issue could be leveraged to
execute arbitrary code with the privileges of that user.

See also :

http://blogs.adobe.com/psirt/2009/07/impact_of_microsoft_atl_vulner.html
http://www.adobe.com/support/security/bulletins/apsb09-11.html

Solution :

Uninstall the Internet Explorer version of Shockwave Player version
11.5.0.600 and earlier, restart the system, and then install version
11.5.0.601 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 40421 ()

Bugtraq ID: 35845

CVE ID: CVE-2009-0901
CVE-2009-2495
CVE-2009-2493

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now