Google Chrome < 2.0.172.37 Multiple Vulnerabilities

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web browser that is affected by multiple
vulnerabilities.

Description :

The version of Google Chrome installed on the remote host is earlier
than 2.0.172.37. Such versions are reportedly affected by multiple
issues :

- A heap overflow exists when evaluating specially crafted
regular expressions in JavaScript. This could lead to a
denial of service or the execution of arbitrary code
within the Google Chrome sandbox. (Issue 14719)

- A memory corruption issue exists in the renderer process
that could cause a denial of service or possibly allow
arbitrary code execution with the privileges of the
logged on user. (CVE-2009-2556)

- Creating a Select object with a very large length can
result in memory exhaustion, causing a denial of service.

See also :

http://www.securityfocus.com/archive/1/504969/100/0/threaded
http://www.nessus.org/u?8f3cdeb6

Solution :

Upgrade to Google Chrome 2.0.172.37 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 39852 (google_chrome_2_0_172_37.nasl)

Bugtraq ID: 35446
35722
35723

CVE ID: CVE-2009-1692
CVE-2009-2555
CVE-2009-2556

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now