Adobe Reader getAnnots() JavaScript Method PDF Handling Memory Corruption (APSB09-06)

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The PDF file viewer on the remote Windows host is affected by a memory
corruption vulnerability.

Description :

The version of Adobe Reader installed on the remote host is earlier
than 9.1.1 / 8.1.5 / 7.1.2. Such versions reportedly fail to validate
input from a specially crafted PDF file before passing it to the
JavaScript method 'getAnnots()' leading to memory corruption and
possibly arbitrary code execution.

See also :

http://www.adobe.com/support/security/advisories/apsa09-02.html
http://www.adobe.com/support/security/bulletins/apsb09-06.html

Solution :

Upgrade to Adobe Reader 9.1.1 / 8.1.5 / 7.1.2 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 38746 (adobe_reader_911.nasl)

Bugtraq ID: 34736

CVE ID: CVE-2009-1492

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now