Google Chrome < 1.0.154.64 Multiple Overflows

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web browser that is affected by multiple
vulnerabilities.

Description :

The version of Google Chrome installed on the remote host is earlier
than 1.0.154.64. Such versions are reportedly affected by multiple
vulnerabilities :

- A failure to properly validate input from a renderer
(tab) process could allow an attacker to crash the
browser and possibly run arbitrary code with the
privileges of the logged on user. (CVE-2009-1441)

- A failure to check the result of integer multiplication
when computing image sizes could allow a specially
crafted image or canvas to cause a tab to crash and
possibly allow an attacker to execute arbitrary code
inside the (sandboxed) renderer process. (CVE-2009-1442)

See also :

http://www.nessus.org/u?35c782d6

Solution :

Upgrade to Google Chrome 1.0.154.64 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 38699 (google_chrome_1_0_154_64.nasl)

Bugtraq ID: 34859

CVE ID: CVE-2009-1441
CVE-2009-1442

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now