Firefox < 3.0.10 Multiple Vulnerabilities

This script is Copyright (C) 2009-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The version of Firefox installed on the remote host is earlier
than 3.0.10. Such versions have multiple vulnerabilities :

- An error in function '@nsTextFrame::ClearTextRun()' could
corrupt the memory. Successful exploitation of this issue
may allow arbitrary code execution on the remote system.
Note this reportedly only affects 3.0.9. (MFSA 2009-23)

- The browser processes a 3xx HTTP CONNECT response before
a successful SSL handshake, which could allow a man-in-
the-middle attacker to execute arbitrary web script in the
context of a HTTPS server. (CVE-2009-2061)

See also :

http://research.microsoft.com/apps/pubs/default.aspx?id=79323
https://www.mozilla.org/en-US/security/advisories/mfsa2009-23/

Solution :

Upgrade to Firefox 3.0.10 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 38200 ()

Bugtraq ID: 34743
35412

CVE ID: CVE-2009-1313
CVE-2009-2061

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now