Mandriva Linux Security Advisory : php-smarty (MDVSA-2009:052)

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

A vulnerability has been identified and corrected in php-smarty :

The _expand_quoted_text function in libs/Smarty_Compiler.class.php in
Smarty 2.6.20 before r2797 allows remote attackers to execute
arbitrary PHP code via vectors related to templates and (1) a
dollar-sign character, aka php executed in templates

Solution :

Update the affected php-smarty and / or php-smarty-manual packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Mandriva Local Security Checks

Nessus Plugin ID: 37766 (mandriva_MDVSA-2009-052.nasl)

Bugtraq ID: 31862

CVE ID: CVE-2008-4810

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now