Mandriva Linux Security Advisory : net-snmp (MDVSA-2008:118)

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

A vulnerability was found in how Net-SNMP checked an SNMPv3 packet's
Keyed-Hash Message Authentication Code (HMAC). An attacker could
exploit this flaw to spoof an authenticated SNMPv3 packet
(CVE-2008-0960).

A buffer overflow was found in the perl bindings for Net-SNMP that
could be exploited if an attacker could convince an application using
the Net-SNMP perl modules to connect to a malicious SNMP agent
(CVE-2008-2292).

The updated packages have been patched to prevent these issues.

Solution :

Update the affected packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
Public Exploit Available : true

Family: Mandriva Local Security Checks

Nessus Plugin ID: 37050 (mandriva_MDVSA-2008-118.nasl)

Bugtraq ID:

CVE ID: CVE-2008-0960
CVE-2008-2292

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now