FreeBSD : mysql -- heap buffer overflow with prepared statements (77420ebb-0cf4-11d9-8a8a-000c41e2cdad)

This script is Copyright (C) 2009-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

There is a buffer overflow in the prepared statements API
(libmysqlclient) when a statement containing thousands of placeholders
is executed.

See also :

http://bugs.mysql.com/bug.php?id=5194
http://dev.mysql.com/doc/mysql/en/News-4.1.5.html
http://www.nessus.org/u?1a8bed5c

Solution :

Update the affected packages.

Risk factor :

High

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 36280 (freebsd_pkg_77420ebb0cf411d98a8a000c41e2cdad.nasl)

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now