PGP Desktop < 9.10 Multiple Local DoS

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote host contains an application that is affected by multiple
vulnerabilities.

Description :

The version of PGP Desktop installed on the remote system is older than
9.10. As such, it reportedly is affected by the following issues :

- The IOCTL handler in 'pgpdisk.sys' fails to perform
sufficient boundary checks on data associated with 'Irp'
objects. A local attacker could exploit this flaw to
crash the system.

- The IOCTL handler in 'pgpwded.sys' fails to perform
sufficient boundary checks on data associated with 'Irp'
objects. A local attacker could exploit this flaw to
crash the system or execute arbitrary code with SYSTEM
privileges.

See also :

http://en.securitylab.ru/lab/PT-2009-01
http://seclists.org/fulldisclosure/2009/Apr/120

Solution :

Upgrade to PGP Desktop version 9.10, which reportedly addresses these
issues.

Risk factor :

Medium / CVSS Base Score : 6.2
(CVSS2#AV:L/AC:H/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 4.9
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 36162 ()

Bugtraq ID: 32991
34490

CVE ID: CVE-2008-5731
CVE-2009-0681

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now