Flash Player 9.0.159.0 / 10.0.22.87 Multiple Vulnerabilities (APSB09-01)

This script is Copyright (C) 2009-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a browser plugin that is affected by
multiple vulnerabilities.

Description :

The remote Windows host contains a version of Adobe Flash Player that
is earlier than 9.0.159.0 / 10.0.22.87. Such versions are reportedly
affected by multiple vulnerabilities :

- A buffer overflow issue that could allow an attacker
to execute arbitrary code with the privileges of the
user running the application. (CVE-2009-0520)

- An input validation vulnerability that leads to a denial
of service attack and could possibly allow for an attacker
to execute arbitrary code. (CVE-2009-0519)

- A vulnerability in the Flash Player settings manager that
could contribute to a clickjacking attack. (CVE-2009-0014)

- A vulnerability with the mouse pointer display that could
contribute to a clickjacking attack. (CVE-2009-0522)

See also :

http://www.nessus.org/u?023bd92b
http://www.adobe.com/support/security/bulletins/apsb09-01.html

Solution :

Upgrade to version 10.0.22.87 or later. If you are unable to
upgrade to version 10, upgrade to version 9.0.159.0 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 35742 (flash_player_apsb09_01.nasl)

Bugtraq ID: 33880
33890

CVE ID: CVE-2009-0114
CVE-2009-0519
CVE-2009-0520
CVE-2009-0522

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now