FreeBSD : pycrypto -- ARC2 module buffer overflow (5a021595-fba9-11dd-86f3-0030843d3802)

This script is Copyright (C) 2009-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

Dwayne C. Litzenberger reports :

pycrypto is exposed to a buffer overflow issue because it fails to
adequately verify user-supplied input. This issue resides in the ARC2
module. This issue can be triggered with specially crafted ARC2 keys
in excess of 128 bytes.

See also :

http://lists.dlitz.net/pipermail/pycrypto/2009q1/000062.html
http://www.nessus.org/u?7d28ad53

Solution :

Update the affected package.

Risk factor :

High

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 35695 (freebsd_pkg_5a021595fba911dd86f30030843d3802.nasl)

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now