Opera < 9.50 Multiple Vulnerabilities

This script is Copyright (C) 2008-2014 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web browser that is affected by several
issues.

Description :

The version of Opera installed on the remote host reportedly is
affected by several issues :

- Improper handling of special characters in page addresses
can make addresses look like other ones, aiding in phishing attacks.

- Specially crafted HTML canvas elements could violate the
same-origin image policy.

- Framed sources contained on the same parent page can modify
each other's location.

See also :

http://www.opera.com/support/search/view/878/
http://www.opera.com/support/search/view/883/
http://www.opera.com/support/search/view/885/
http://www.opera.com/docs/changelogs/windows/950/

Solution :

Upgrade to Opera version 9.50 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.2
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 33168 ()

Bugtraq ID: 29684

CVE ID: CVE-2008-2714
CVE-2008-2715
CVE-2008-2716

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now