VMware VIX API Multiple Buffer Overflow Vulnerabilities

This script is Copyright (C) 2008-2015 Tenable Network Security, Inc.


Synopsis :

The remote host contains an application that is affected by multiple
buffer overflow vulnerabilities.

Description :

VMware VIX, an application programming interface to manipulate virtual
machines is installed on the remote host.

The installed version of VMware VIX API is affected by multiple buffer
overflow vulnerabilities. Successful exploitation of these issues
could allow arbitrary code execution on the host operating system from
the guest system.

See also :

http://www.vmware.com/security/advisories/VMSA-2008-0009.html

Solution :

Upgrade to VMware VIX API 1.1.4 or higher.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 5.3
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 33106 ()

Bugtraq ID: 29552

CVE ID: CVE-2008-2100

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now