Foxit Reader < 2.3 Build 2923 util.printf() Floating Point Specifier RCE

This script is Copyright (C) 2008-2016 Tenable Network Security, Inc.


Synopsis :

A PDF viewer installed on the remote host is affected by a remote code
execution vulnerability.

Description :

The version of Foxit Reader installed on the remote Windows host is
prior to 2.3 Build 2923. It is, therefore, affected by a boundary
error that is triggered when parsing format strings containing a
floating point specifier in the util.printf() JavaScript function. An
attacker can exploit this issue, by tricking a user into opening a
crafted PDF file, to execute arbitrary code with the user's
privileges.

See also :

http://secunia.com/secunia_research/2008-18/advisory/
https://www.foxitsoftware.com/support/security-bulletins.php
https://www.foxitsoftware.com/company/press.php?id=40

Solution :

Upgrade to Foxit Reader version 2.3 Build 2923 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 32396 (foxit_reader_2_3_2912.nasl)

Bugtraq ID: 29288

CVE ID: CVE-2008-1104

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now