Sun OpenOffice.org < 2.4 Multiple Vulnerabilities

This script is Copyright (C) 2008-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a program that is affected by multiple
vulnerabilities.

Description :

The version of Sun Microsystems OpenOffice.org installed on the
remote host is affected by several issues :

- Heap overflow and arbitrary code execution
vulnerabilities involving ODF text documents with
XForms (CVE-2007-4770/4771).

- Heap overflow and arbitrary code execution
vulnerabilities involving Quattro Pro files
(CVE-2007-5745/5747).

- Heap overflow and arbitrary code execution
vulnerabilities involving EMF files (CVE-2007-5746).

- Heap overflow and arbitrary code execution
vulnerabilities involving OLE files (CVE-2008-0320).

See also :

http://www.openoffice.org/security/cves/CVE-2007-5746.html
http://www.openoffice.org/security/cves/CVE-2007-4770.html
http://www.openoffice.org/security/cves/CVE-2007-5745.html
http://www.openoffice.org/security/cves/CVE-2008-0320.html

Solution :

Upgrade to Sun Microsystems OpenOffice.org version 2.4 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 31968 ()

Bugtraq ID: 28819

CVE ID: CVE-2007-4770
CVE-2007-4771
CVE-2007-5745
CVE-2007-5746
CVE-2007-5747
CVE-2008-0320

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now