GLSA-200804-05 : NX: User-assisted execution of arbitrary code

This script is Copyright (C) 2008-2017 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200804-05
(NX: User-assisted execution of arbitrary code)

Multiple integer overflow and buffer overflow vulnerabilities have been
discovered in the X.Org X server as shipped by NX and NX Node
(vulnerabilities 1-4 in GLSA 200801-09).

Impact :

A remote attacker could exploit these vulnerabilities via unspecified
vectors, leading to the execution of arbitrary code with the privileges
of the user on the machine running the NX server.

Workaround :

There is no known workaround at this time.

See also :

https?://www.gentoo.org/security/en/glsa/glsa-200801-09.xml
https://security.gentoo.org/glsa/200804-05

Solution :

All NX Node users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-misc/nxnode-3.1.0-r2'
All NX users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-misc/nx-3.1.0-r1'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 31836 (gentoo_GLSA-200804-05.nasl)

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now