openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-4810)

This script is Copyright (C) 2008-2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update fixes multiple bugs in php :

- use system pcre library to fix several pcre
vulnerabilities (CVE-2007-1659, CVE-2006-7230,
CVE-2007-1660, CVE-2006-7227 CVE-2005-4872,
CVE-2006-7228)

- Flaws in processing multi byte sequences in
htmlentities/htmlspecialchars (CVE-2007-5898)

- overly long arguments to the dl() function could crash
php (CVE-2007-4825)

- overy long arguments to the glob() function could crash
php (CVE-2007-4782)

- overly long arguments to some iconv functions could
crash php (CVE-2007-4840)

- overy long arguments to the setlocale() function could
crash php (CVE-2007-4784)

- the wordwrap-Function could cause a floating point
exception (CVE-2007-3998)

- overy long arguments to the fnmatch() function could
crash php (CVE-2007-4782)

- incorrect size calculation in the chunk_split function
could lead to a buffer overflow (CVE-2007-4661)

- Flaws in the GD extension could lead to integer
overflows (CVE-2007-3996)

- The money_format function contained format string flaws
(CVE-2007-4658)

- Data for some time zones has been updated

Solution :

Update the affected apache2-mod_php5 packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now