SuSE 10 Security Update : xorg-x11-server (ZYPP Patch Number 2449)

This script is Copyright (C) 2007-2012 Tenable Network Security, Inc.


Synopsis :

The remote SuSE 10 host is missing a security-related patch.

Description :

X server: ProcRenderAddGlyphs Memory Corruption Vulnerability. This
update fixes a memory corruption in the ProcRenderAddGlyphs() function
(CVE-2006-6101). X server: ProcDbeGetVisualInfo Memory Corruption
Vulnerability. This update fixes a memory corruption in the
ProcDbeGetVisualInfo() function (CVE-2006-6102). X server:
ProcDbeSwapBuffers Memory Corruption Vulnerability. This update fixes
a memory corruption in the ProcDbeSwapBuffers() function.
(CVE-2006-6103)

See also :

http://support.novell.com/security/cve/CVE-2006-6101.html
http://support.novell.com/security/cve/CVE-2006-6102.html
http://support.novell.com/security/cve/CVE-2006-6103.html

Solution :

Apply ZYPP patch number 2449.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 29606 ()

Bugtraq ID:

CVE ID: CVE-2006-6101
CVE-2006-6102
CVE-2006-6103

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now