SuSE 10 Security Update : OpenOffice_org (ZYPP Patch Number 2651)

This script is Copyright (C) 2007-2012 Tenable Network Security, Inc.


Synopsis :

The remote SuSE 10 host is missing a security-related patch.

Description :

Following security problems were fixed in OpenOffice_org :

This update also brings OpenOffice_org to version 2.0.4.17, same as
SUSE Linux Enterprise Desktop 10 and contains lots of bugfixes.

It also contains support for the Office XML converter hooks.

- Various problems were fixed in the Wordperfect converter
library libwpd in OpenOffice_org which could be used by
remote attackers to potentially execute code or crash
OpenOffice_org. (CVE-2007-0002)

- A stack overflow in the StarCalc parser could be used by
remote attackers to potentially execute code by
supplying a crafted document. (CVE-2007-0238)

- A shell quoting problem when opening URLs was fixed
which could be used by remote attackers to execute code
by supplying a crafted document and making the user
click on an embedded link. (CVE-2007-0239)

See also :

http://support.novell.com/security/cve/CVE-2007-0002.html
http://support.novell.com/security/cve/CVE-2007-0238.html
http://support.novell.com/security/cve/CVE-2007-0239.html

Solution :

Apply ZYPP patch number 2651.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 29365 ()

Bugtraq ID:

CVE ID: CVE-2007-0002
CVE-2007-0238
CVE-2007-0239

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now