openSUSE 10 Security Update : seamonkey (seamonkey-2432)

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This security update brings Mozilla SeaMonkey to version 1.0.7.

http://www.mozilla.org/projects/security/known-vulnerabilities.html
for more details.

It includes fixes to the following security problems:
CVE-2006-6497/MFSA2006-68: Crashes with evidence of memory corruption
were fixed in the layout engine. CVE-2006-6498/MFSA2006-68: Crashes
with evidence of memory corruption were fixed in the JavaScript
engine. CVE-2006-6499/MFSA2006-68: Crashes regarding floating point
usage were fixed. CVE-2006-6500/MFSA2006-69: This issue only affects
Windows systems, Linux is not affected. CVE-2006-6501/MFSA2006-70: A
privilege escalation using a watch point was fixed.
CVE-2006-6502/MFSA2006-71: A LiveConnect crash finalizing JS objects
was fixed. CVE-2006-6503/MFSA2006-72: A XSS problem caused by setting
img.src to javascript: URI was fixed. CVE-2006-6504/MFSA2006-73: A
Mozilla SVG Processing Remote Code Execution was fixed.
CVE-2006-6505/MFSA2006-74: Some Mail header processing heap overflows
were fixed. CVE-2006-6506/MFSA2006-75: The RSS Feed-preview referrer
leak was fixed. CVE-2006-6507/MFSA2006-76: A XSS problem using outer
window's Function object was fixed.

See also :

http://www.mozilla.org/projects/security/known-vulnerabilities.html

Solution :

Update the affected seamonkey packages.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now