openSUSE 10 Security Update : php5 (php5-1590)

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update fixes the following security issues: - invalid charactes
in session names were not blocked - a bug in zend_hash_del() allowed
attackers to prevent unsetting of some variables - bugs in the
substr_compare() and wordwrap function could crash php (CVE-2006-1991,
CVE-2006-1990) - a memory leak in the imagecreatefromgif() function

Solution :

Update the affected php5 packages.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 27389 ()

Bugtraq ID:

CVE ID: CVE-2006-1990
CVE-2006-1991

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now