openSUSE 10 Security Update : moodle (moodle-3959)

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update fixes the following issues :

- possible remote file inclusion (CVE-2007-1429)

- XSS injection in SCORM 1.2 reports

- Fixed XSS in login block

Additionally changes :

- Fixed visibility of site blogs

- moodle-config.php is now located in /etc/moodle/

- added safe_mode and session.save_handler as php options

Solution :

Update the affected moodle packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 27351 ()

Bugtraq ID:

CVE ID: CVE-2007-1429

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now