openSUSE 10 Security Update : flash-player (flash-player-3889)

This script is Copyright (C) 2007-2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

The Adobe Flash Player was updated to version 7.0.70.0 on SUSE Linux
10.0 and to version 9.0.48.0 on SUSE Linux 10.1 and openSUSE 10.2 to
fix several security problems :

CVE-2007-3456: An input validation error has been identified in Flash
Player 9.0.45.0 and earlier versions that could lead to the potential
execution of arbitrary code. This vulnerability could be accessed
through content delivered from a remote location via the user's web
browser, email client, or other applications that include or reference
the Flash Player.

CVE-2007-3457: An issue with insufficient validation of the HTTP
Referer has been identified in Flash Player 8.0.34.0 and earlier. This
issue does not affect Flash Player 9. This issue could potentially aid
an attacker in executing a cross-site request forgery attack.

CVE-2007-2022: The Linux and Solaris updates for Flash Player 7
(7.0.70.0) address the issues with Flash Player and the Opera and
Konqueror browsers described in Security Advisory APSA07-03. These
issues do not impact Flash Player 9 on Linux or Solaris.

The affected webbrowsers Opera and konqueror have already been fixed
independendly.

Solution :

Update the affected flash-player package.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 27221 ()

Bugtraq ID:

CVE ID: CVE-2007-2022
CVE-2007-3456
CVE-2007-3457

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now