openSUSE 10 Security Update : awstats (awstats-1612)

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update fixes remote code execution vulnerabilities in awstats.
Since backporting awstats fixes is error prone we have upgraded it to
upstream version 6.6, which also includes new features. Security
issues fixed: - CVE-2006-2237: missing sanitizing of the 'migrate'
parameter. #173041 - CVE-2006-2644: missing sanitizing of the
'configdir' parameter. #173041 - Make sure open() only opens files for
read/write by adding explicit < and >.

Solution :

Update the affected awstats package.

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)
Public Exploit Available : true

Family: SuSE Local Security Checks

Nessus Plugin ID: 27163 ()

Bugtraq ID:

CVE ID: CVE-2006-2237
CVE-2006-2644

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now